4 wheel Engaged light on when in 2 wheel drive - Can-Am Maverick Forum : 2013+ Can-Am Maverick Forums
 
LinkBack Thread Tools
post #1 of 4 (permalink) Old 06-13-2013, 09:31 PM Thread Starter
Junior Member
 
Join Date: Jun 2013
Posts: 7
4 wheel Engaged light on when in 2 wheel drive

Just wondering if anyone else has had this happen. When I first take off on a ride the 4 wheel drive light comes on at half to full throttle for awhile if I let out the light goes out smash it light comes back on. This only goes on tell the everything gets up to temp. Thinking it's the cold oil if the diffs making this happen. It's only the light coming on, 4 wheel drive is not engaging.
Jahonda44 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 07-21-2013, 03:41 AM
Junior Member
 
Join Date: Jul 2013
Posts: 1
Quote:
Originally Posted by Jahonda44 View Post
Just wondering if anyone else has had this happen. When I first take off on a ride the 4 wheel drive light comes on at half to full throttle for awhile if I let out the light goes out smash it light comes back on. This only goes on tell the everything gets up to temp. Thinking it's the cold oil if the diffs making this happen. It's only the light coming on, 4 wheel drive is not engaging.
Were you able to sort the problem? I have never heard about it..
MarcBradley is offline  
post #3 of 4 (permalink) Old 08-14-2013, 11:38 AM
Junior Member
 
Join Date: Jan 2013
Posts: 19
mine had this problem too a couple of times actually, the dealership told me it was due to my sport low kit that I installed, I don't buy that but we will wait and see
rchad is offline  
 
post #4 of 4 (permalink) Old 10-25-2013, 06:28 PM Thread Starter
Junior Member
 
Join Date: Jun 2013
Posts: 7
Never figured it out. Still happens but now it happens even when it's hot. I don't care got 2200 miles on it and haven't had any trouble. I'm just gonna keep drive it tell she breaks,
Jahonda44 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am Maverick Forum : 2013+ Can-Am Maverick Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome