2013 Mav - Can-Am Maverick Forum : 2013+ Can-Am Maverick Forums
 
LinkBack Thread Tools
post #1 of 1 (permalink) Old 02-15-2019, 02:16 AM Thread Starter
Junior Member
 
Join Date: Feb 2019
Posts: 1
2013 Mav

I just bought a 2013 maverick 1000 but when I shift it into low it says on the dash that it’s in high and when I put it into high it won’t engage and have to put the shifter in between H and L gear.. also it drives perfectly fine in low now but when it gets up to 80-85 in high on deceleration it pops out of gear and sounds like it’s grinding
Dbeach93 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Can-Am Maverick Forum : 2013+ Can-Am Maverick Forums forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome